ERROR: The version of the .NET Framework Configuration Provider

In my case I am trying to migrate a website running on IIS 7.5 and Windows Server 2008 to another machine running IIS 10 and Windows Server 2016.

Windows 2008 VPS via ERROR: The version of the .NET Framework Configuration Provider.